Instrument Cluster Ford Crown Victoria (2006-2011) Rebuild

  • Sale
  • Regular price $100.00


 Attention:

This rebuild service requires that you:

  • Verify that your cluster matches the product photo

  • Remove your cluster

  • Carefully pack and ship it to us - Instructions

  • We rebuild it and ship it back to you

  • Re-install your cluster

Known issues we fix:

  • Dead or blank odometer

  • Dead or intermittent gauges

What this rebuild includes:

Year/Make/Model(s) applicable:

  • 2006 Ford Crown Victoria

  • 2007 Ford Crown Victoria

  • 2008 Ford Crown Victoria

  • 2009 Ford Crown Victoria

  • 2010 Ford Crown Victoria

  • 2011 Ford Crown Victoria

  • Others may apply

Part Number(s) applicable:

  • 6W73-10849-AK
  • 6W73-10849-BK
  • 6W73-10849-CJ
  • 6W73-10849-CK

  • 6W73-10849-DK
  • 6W73-10849-DJ
  • 6W73-10849-EK
  • 6W73-10849-FK
  • 6W73-10849-GK
  • 6W73-10849-HK
  • 7W73-10849-AB
  • 7W73-10849-AC
  • 7W73-10849-BB
  • 7W73-10849-BC
  • 7W73-10849-CB
  • 7W73-10849-CC

  • 7W73-10849-DB
  • 7W73-10849-DC
  • 7W73-10849-EB
  • 7W73-10849-ED
  • 7W73-10849-FB
  • 7W73-10849-FC
  • 7W73-10849-GB
  • 7W73-10849-GD
  • 7W73-10849-HB
  • 7W73-10849-HD
  • 8W73-10849-AA
  • 8W73-10849-AB
  • 8W73-10849-BA
  • 8W73-10849-BB
  • 8W73-10849-CA
  • 8W73-10849-CB

  • 8W73-10849-DA
  • 8W73-10849-DB
  • 8W73-10849-EA
  • 8W73-10849-EC
  • 8W73-10849-FA
  • 8W73-10849-FB
  • 8W73-10849-FC
  • 8W73-10849-GA
  • 8W73-10849-GB
  • 8W73-10849-HA
  • 8W73-10849-HB
  • 9W73-10849-AA
  • 9W73-10849-AB
  • 9W73-10849-BA
  • 9W73-10849-BB
  • 9W73-10849-CA

  • 9W73-10849-CB

  • 9W73-10849-DA
  • 9W73-10849-DB
  • 9W73-10849-EA
  • 9W73-10849-EB
  • 9W73-10849-EC
  • 9W73-10849-FA
  • 9W73-10849-FB
  • 9W73-10849-FC
  • Others may apply

Our new website includes a new review platform. If you'd like to see testimonials from our previous website, click here. 

 


Customer Reviews

Based on 1 review
100%
(1)
0%
(0)
0%
(0)
0%
(0)
0%
(0)
K
Keith Michaels
Simply works

09 Crown Vic retired PD, cluster worked intermittently. Pulled it , sent it out, they rebuilt it, sent it back and I reinstalled. Cluster now works, it’s that simple. Hopefully I’ll never need another cluster rebuilt but if I do I know where I’m sending it.

Back to the top